HTC Sense 3.0 not arriving on older phones

When HTC announced the HTC Sensation recently, they also showed off the latest version of HTC Sense in the promo video. Since the new UI looks pretty rad, someone sent a tweet to HTC asking them if the new sense would arrive on his Desire HD. HTC replied with:

“due to Sense’s hardware requirements, only our newest devices (Flyer, EVO 3D, Sensation) will be able to support it.”

From the examples mentioned in the tweet, it looks like not even the newer phones such as the Incredible S/2 or Desire S will be getting the new UI. The Flyer has a 1.5GHz processor while the EVO 3D and Sensation both back dual-core processors, signifying how much processing power the phones will need to run. But since this is Android we’re talking about, I’m pretty sure some developers will port it over to older phones anyway. Hit the break to watch the HTC Sensation promo video:

This article was filed in Homepage > Cellphones and was tagged with Android, HTC, htc sense and sense ui.
Like us, and get the best stories

User Comments