ios older appAmid the excitement for the release of Grand Theft Auto 5, we have a feeling you may have forgotten iOS 7 will be released to select iOS devices starting tomorrow. Since not every iOS device will be able to upgrade to iOS 7, Apple is making sure you’re able to download the absolute last compatible version of an application so you don’t run into any issues with your aging iOS devices.

The new feature prompts you to download the last compatible version of an application if the latest version isn’t compatible with the current version of iOS you have running. If you happen to have an iPhone that is below an iPhone 4, you’ll certainly get some use out of this feature, although at this point, we would seriously encourage you to upgrade your device to something a little more modern.

Seeing how the iPhone 5C and iPhone 5S are releasing on September 20, we think now would be a great time for you to use your hard-earned upgrade, although if you have been carrying around an iPhone 3G or iPhone 3GS for this long, we’re sure you’ll once again completely ignore the latest iPhone.

Filed in Apple >Cellphones . Tags: app store and iPhone. Source: reddit
User Comments