Own a device from Apple that runs on iOS 5.0.1, and you have always wanted to unlock it but never got around doing so? Here is news for you – ultrasn0w 1.2.5 is now available over at Cydia, offering support for unlocking even more devices under iOS 5.0.1. You will need to be in possession of a compatible baseband beforehand if the unlock is to work as intended. As for the compatible devices and basebands, they would comprise of 04.26.08, 05.11.07, 05.12.01, 05.13.04 and 06.15.00 for the iPhone 3GS, and 1.59.00 for the iPhone 4. For those who want to upgrade from an older firmware, just preserve your baseband using a program such as sn0wbreeze should you require an unlock. As usual, do make a backup of all your data before as you can never tell whether you are the unlucky few whom Murphy decides to strike there and then. As for folks who have already given it a go, how do you find the experience? Nail biting, or just a walk in the park?

Filed in Apple..